News


Magento 2.3 has stopped to support PHP < 7.1.3 since 2018-11-29 (1)
The `app/functions.php` file is deprecated in Magento 2.3 since 2018-09-07 (1)
Since 2017-09-27, Magento 2.3 includes a new «Rush» design theme (2)
Magento has failed to implement the new «Rush» design theme to the 2.3 release (1)
The current Magento 2.2 development branch becomes to support PHP 7.1 (1)
PHPUnit has been upgraded from 4.1.0 to 6.2.x in Magento 2.2.0-RC1.8 (1)
The HHVM compatibility will be dropped since Magento 2.2 (1)
Magento 2.3 requires `zendframework/zend-mail` package (the Mail component from Zend Framework 2) since 2017-07-06 (1)
Magento 2.3 requires the `bcmath` PHP extension since 2017-04-19 (1)
Magento 2.3 includes a new `urlInput` UI Component since 2018-03-19 (1)
Since 2017-10-15, Magento 2.2 and 2.3 require the `mod_version` Apache module, but do not mention it in their system requirements (2)
Magento 2.3 has removed its version information from the `composer.json` files since 2018-04-05 (2)
Magento 2.3 has dropped support for PHP 7.0 since 2018-03-01 (2)
Magento 2.3 became compatible with PHP 7.2 since 2018-03-01 (2)
The standard error messages have been significantly changed in Magento 2.3 at 2018-01-22 (1)
The `theme.js` and `responsive.js` files of the Blank design theme has been moved to the `Magento_Theme` folder since Magento 2.2 (1)
The base router (`Magento\Framework\App\Router\Base`) ordering has been changed from 20 to 30 in Magento 2.2.2 at 2017-10-15 (3)
Since 2017-12-08, Magento 2.3 includes a new «GraphQlCustomer» (`Magento_GraphQlCustomer`) module (2)
Since 2017-12-04, Magento 2.3 includes a new «GraphQlEav» (`Magento_GraphQlEav`) module (2)
Since 2017-12-04, Magento 2.3 includes a new «GraphQlConfigurableProduct» (`Magento_GraphQlConfigurableProduct`) module (2)
Since 2017-12-04, Magento 2.3 includes a new «GraphQlCatalog» (`Magento_GraphQlCatalog`) module (2)
Since 2017-10-25, Magento 2.3 includes a new «GraphQl» (`Magento_GraphQl`) module (2)
Since 2017-11-03, Magento 2.3 includes a new «Tinymce3» (`Magento_Tinymce3`) module (2)
Since 2017-11-03, Magento 2.3 uses TinyMCE 4.6 instead of TinyMCE 3 as the native WYSIWYG editor (2)
Fonts Awesome includes a Magento icon since version 5 (1)
The Magento 2 team has just started to work on its own IntelliJ PHPStorm plugin (1)
Since 2017-11-02, the Magento 2.2 and 2.3 development branches include a new «Instant Purchase» (`Magento_InstantPurchase`) module (1)
The «develop» and «2.3-develop» git branches now contain an identical code (3)
The default Magento 2 code branch («develop») has now 2.3-dev version number since 2017-07-28 (2)
How to clone the Magento 2.3 git branch («develop» or «2.3-develop»)? (2)