The browser form autocompletion is wrongly enabled for the admin config settings (and my fix)

This is a long-term bug from Magento 1.x and still is in Magento 2.
Magento does not disable browser form autocompletion and it leads to very odd behaviour because the browser fill some fields with wrong (and sometimes potentially dangerous) data:

As you can see the browser filled custom extension OAuth credentials settings with wrong data (Magento admin login and password). This is wrong (because the fields has a different meaning) and potentially dangerous.

Surely autocompleting need to be disabled for admin config settings.
I have done it with a plugin but would like to see such functionality in the core.

<type name='\Magento\Framework\Data\Form\Element\AbstractElement'>
namespace Df\Framework\Data\Form\Element;
use Magento\Framework\Data\Form\Element\AbstractElement;
class AbstractElementPlugin {
	 * @link
	 * @see \Magento\Framework\Data\Form\Element\AbstractElement::getHtmlAttributes()
	 * @param AbstractElement $subject
	 * @param string[] $result
	 * @return string[]
	public function afterGetHtmlAttributes(AbstractElement $subject, $result) {
		$result[]= 'autocomplete';
		return $result;

	 * @link
	 * @see \Magento\Framework\Data\Form\Element\AbstractElement::getElementHtml()
	 * @param AbstractElement $subject
	 * @return array()
	public function beforeGetElementHtml(AbstractElement $subject) {
		$subject['autocomplete'] = 'new-password';
		return [];

See also my solution for backend login autocompletion.