Why is not the static content generated automatically despite my store is in the «developer» mode?

After enabled developer mode static file are not generating automatically. in my local system.

php bin/magento deploy:mode:set developer

How to resolve this.

First of all, check whether your store really is in the developer mode.

yes i checked get below output…

$ php bin/magento deploy:mode:show
Current application mode: developer.

The static content is regenerated only when it is absent.
So, delete it and reload a store’s page.

I have tried now. delete the var/ session and cache folders and pub/static folder.

run the website… issue not resolved ?

Ensure you have the proper filesystem permissions.

now Checked the files permission… perfect… !

Try to set the MAGE_MODE environment variable for the web server.

Now 1st i tried to enable in .htaccess file and in magento root folder

Then i set the SetEnv MAGE_MODE “developer” exits vhost tag

/etc/apache2/sites-available$ sudo nano 000-default.conf

stop the start the apache server… not resolved.