The payment block shows «Please specify shipping method» while a third-part checkout extension is used

payment
ckeckout

(Jamie Monk) #1

Hi Dmitry

I’m getting an error when I’m trying to place an order on the website, it’s saying choose a shipping method - but clearly one is already selected. It will work if I choose a shipping method that is free but not if it’s chargeable.


(Dmitry Fedyuk) #2

How to reproduce it?


(Jamie Monk) #3
  • Go to http://rawdogfood.website
  • Add something to the cart
  • Choose a paid shipping method
  • Enter a stripe test card
  • Click place order now

UPDATE: Now it doesn’t do anything. You get a “Please wait” under the Place Order Now button then nothing happens.


(Dmitry Fedyuk) #4

I have spent my time again and have successfully places an order (from the first attempt) totally in accordance with your description:


(Jamie Monk) #5

I’ve just refreshed my cache on browser and tried again.

This time I got the same message as the original post:


(Dmitry Fedyuk) #6

How can I reproduce it?


(Jamie Monk) #7

I added this product to the cart: http://rawdogfood.website/complete-meals-mixed-pack-10kg.html

Then tried to checkout.

I used a local postcode, so try: TN23 5GN
Then choose the £5 shipping method which should be selected by default


(Dmitry Fedyuk) #8

OK, I made the third attempt and have successfully ordered the product you specified, without any errors.




(Dmitry Fedyuk) #9

Finally, I reproduced the failure.
Your postal code TN23 5GN and £5 shipping method combination really make the failure reproducible.
But the failure is not caused by the Stripe extension.
To prove it, I have disabled the Stripe extension and chose the Cash On Collection payment method, and got the same failure.
Please see the screenshots below.
I think the failure is caused by your third-party checkout extension (Magestore One Step Checkout), or by the Local Delivery shipping extension, or by some other extension.
I can solve such problems with other extensions on the terms of my paid support service.