Magento 2.3 requires `zendframework/zend-mail` package (the Mail component from Zend Framework 2) since 2017-07-06

system-requirements
zend-framework
email
magento23
zend-mail

(Dmitry Fedyuk) #1

Magento < 2.3 does not require zendframework/zend-mail.