How to set «GD2» as the default image adapter from the command line?

configuration-advanced
php-settings
backend
image
command-line
configuration-advanced-developer
imagick

(Dmitry Fedyuk) #1

Magento ≥ 2.2

bin/magento config:set dev/image/default_adapter GD2
bin/magento cache:clean

Magento < 2.2

mysql --host=<host> --user=<user> --password=<password> -D <database> -e "\
	UPDATE core_config_data SET value = 'GD2' WHERE 'dev/image/default_adapter' = path; \
";
bin/magento cache:clean

How to enable or disable the static content signing?
How to disable the «Minify JavaScript Files» option from the command line?
How to disable the «Minify CSS Files» option from the command line?
How to disable the «Merge CSS Files» option from the command line?
How to disable the «Enable Javascript Bundling» option from the command line?
How to disable the «Merge JavaScript Files» option from the command line?
How to fix «The specified image adapter cannot be used because of: Required PHP extension 'Imagick' was not loaded.»?
(Dmitry Fedyuk) #2

See also: