How do I eliminate the «Consumer "async.operations.all" skipped as required connection "amqp" is not configured» message from logs?

The best way to eliminate this message is just to install and configure RabbitMQ:

But sometimes I do not have the root access to the website’s server, so I use workaround:

Step 1

Run

bin/magento queue:consumers:list

and copy the list of all consumers except async.operations.all:
01

Step 2

Add to app/etc/env.php:

    ,'cron_consumers_runner' => [
        'consumers' => [
           # enumerate your consumers here
            'codegeneratorProcessor'
            ,'exportProcessor'
            ,'product_action_attribute.update'
            ,'product_action_attribute.website.update'
        ]
        ,'cron_run' => true
        ,'max_messages' => 2
        ,'single_thread' => true
    ]
    ,'queue' => ['consumers_wait_for_messages' => 0]

Step 3

bin/magento module:disable Magento_Amqp
bin/magento module:disable Magento_WebapiAsync
bin/magento cache:clean

Step 4

Check the result:

bin/magento cron:run --group=consumers --bootstrap=standaloneProcessStarted=1

The «Consumer “async.operations.all” skipped as required connection “amqp” is not configured» message should not be logged anymore.