«Could not find package <name> at any version for your minimum-stability (alpha)»

composer
composer-package

(Poongudivanan N) #1

Hi have create test magento 2 package and push to GitHub and also submit into packagist.org.

Name : composer require mabu/shopfinder

i use this code into my local systems getting error like :slight_smile:

[InvalidArgumentException]
Could not find package mabu/shopfinder at any version for your minimum-stability (alpha). Check the package spelling or your minimum-stabi
lity

require [–dev] [–prefer-source] [–prefer-dist] [–no-plugins] [–no-progress] [–no-update] [–update-no-dev] [–update-with-dependencies] [–ignore-platform-reqs] [–sort-packages] [-o|–optimize-autoloader] [-a|–classmap-authoritative] [–] []…


(Dmitry Fedyuk) #2

Publish the package’s composer.json file here.


(Poongudivanan N) #4

composer.json (520 Bytes)

anything wrong with my json file…?


(Dmitry Fedyuk) #5

Publish it here as a formatted JSON text, not as an attachment.


(Poongudivanan N) #6
{

“name”: “magento2abu/root”,
“description”: “Shopfinder Module for Magento 2”,
“type”: “magento2-module”,
“version”: “1.0.0”,
“homepage”: “https://github.com/magento2abu/root”,
“license”: [
“OSL-3.0”,
“AFL-3.0”
],
“repositories”: {“type”: “vcs”,“url”: “https://github.com/magento2abu/root”},
“require”: {
“php”: “~5.6.0|7.0.",
“magento/framework”: "100.1.

},
“autoload”: {
“files”: [
“registration.php”
],
“psr-4”: {
“Mabu\Shopfinder\”: “”
}
}
}


(Dmitry Fedyuk) #7

The package’s name magento2abu/root does not match the name mabu/shopfinder in the composer’s error message, so the message is related to another package.


(Dmitry Fedyuk) #8

2 posts were split to a new topic: Should a package’s name in the package’s composer.json file be the same as the name for the composer require command?