If a comma is used as a thousands separator, then a product's price is incorrectly saved on the product's save

price-format

(Tim Lee) #1

Hi Dmitry,

Is it possible to exclude input field for thousands separator feature? When it (thousands separator) is enabled and I would like to edit previously generated product, the price with thousands separator (as attachment 20180828-01.png) would save as 1 (as attachment 20180828-02.png). Thus I have to remove thousands separator every time.

20180828-01
20180828-02

Tim


«Price Format» extension
(Dmitry Fedyuk) #2

Please provide your website’s URL.


(Dmitry Fedyuk) #4

You should buy the extension’s license first (see the first post in the topic).
Then I will solve your problem.


(Dmitry Fedyuk) #5

OK, thanks for the purchase!
Please provide me SSH access to your website’s server.
I think the problem is with your specific locale settings.
I will make a local copy of your website and debug the problem.


(Tim Lee) #6

No problem and I’ll send you the SSH info to your email: admin@mage2.pro


(Dmitry Fedyuk) #7

@tim

Fixed in the 1.1.0 version.
I have already upgraded the module in your website.


(Dmitry Fedyuk) #8

A post was split to a new topic: «Special Price» and «Сost» are set to 0 on a product save