«bin/magento setup:di:compile» leads the PHP 7.1 interpreter to a «segment error»

php71
mage2pro-core
php-segmentation-fault

(Paul King) #1

Thanks Dmitry,

We have tried to install again but it keeps getting stuck when trying to compile (stage 3) giving “segment error”. And the back-end of Magento2 just gives 500 server error.

Really appreciate your help.

Kind regards, Paul


mage2pro/core 2.8.19 can break some backend pages
(Dmitry Fedyuk) #2

Hi @Paul_King,
You should not «install it again», you should upgrade.
I have tried it myself, but now your server is misconfigured, and the composer update command does not work at all:

«The “https://repo.magento.com/packages.json” file could not be downloaded: allow_url_fopen must be enabled in php.ini».

Please fix this issue first.


(Paul King) #3

Thanks Dmitry,

I have configured server correctly. Composer update now running successfully.

Kind regards, Paul


(Dmitry Fedyuk) #4

Yes, I was able to reproduce the issue.
My analysis is here: How to workaround a «Segmentation failt» failure on bin/magento setup:di:compile?

Your Magento 2 installation is already in the developer mode, so I just followed the «Method 1» from the article above, and have successfully installed the Stripe extension.


Unable to uncheck the «Test Mode» checkbox
(Paul King) #5

Thank you very much Dmitry, appreciate your fast help and support.

Kind regards, Paul


(Dmitry Fedyuk) #6

A post was split to a new topic: I am trying to untick the test mode box and save then flush cache. But when I go back to stripe settings they have all stayed the same they just wont change or save.


(Dmitry Fedyuk) #7

Hello Paul,
I have found the cause of the «Segmentation fault» failure, and fixed it in the my latest versions (mage2pro/core 2.8.36, mage2pro/stripe 1.9.26).